Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bekanntmachungen
Client startet nicht (vollständig)
#1
Liebes NM-Team,

der Notenmanager ist bei uns mit postgres-Datenbank installiert. Seit Beginn diesen Schuljahres haben wir Probleme mit dem Aufruf der NManagerSV.exe auf Client-PC.
Die Datei NManagerSV.exe wird über eine Netzwerkfreigabe gestartet, die auch als NM Basisverzeichnis definiert ist. Auf den Clients selbst sind die Programm-DLLs über die Clientinstallation hinterlegt. Die ODBC-Treiber sind auch vorhanden. Der Port 5432 ist freigeschalten und der Zugriff ist von einigen Rechnern auch möglich. Da die PC alle über das gleiche Windows-Image verfügen, unterscheiden sich die Zugriffe nur durch die Rechte des jeweiligen Benutzers. Beim Notenmanager-Verzeichnis auf dem Server sind die Freigabe und die NTFS-Berechtigungen aber für alle Benutzergruppen aber gleich eingestellt.

Fehlerbild: Das Notenmanager-Fenster (Splashscreen) öffnet sich auf manchen Clients und schliesst sich wieder bevor das Hauptfenster geladen wurde.
Betriebssystem: Windows 10 Pro 1903

Auszug aus der Log-Datei im Basisverzeichnis (Fehlermeldung: Fehler beim Programmstart: Ungültiges Bild. ):
# 01.10.2019, 16:17:03
------------------------------------------------------------------
SessionInfo
------------------------------------------------------------------
Programmstart   : 01.10.2019 16:17:03
Rechnername     : PC-VN-30
Betriebssytem   : Unbekannte Version
ADO-Version     : 10.0
Adminrechte     : Falsch
Prog-Version    : 4.6.34
Prog-Verzeichnis: \\SERVER-APP\Notenmanager\
Datenbank       : PostgreSql
Basisverzeichnis: \\server-app\Notenmanager\;;;;;;;;;;1;;;;PC-VN-30
----------------------------------------
# 01.10.2019, 16:17:03
Konfiguration aus nmsv.conf gelesen;;;;;;;;;;1;;;;PC-VN-30
----------------------------------------
# 01.10.2019, 16:17:03
------------------------------------------------------------------
Debug-Info
------------------------------------------------------------------
Commandline          :
NM-Verz. Conf        : \\server-app\Notenmanager\
NM-Verz. Resolved    : \\server-app\Notenmanager\
Lesezugriff vor Init : Wahr
Lesezugriff nach Init: Wahr
Log-Verz. Resolved   : \\server-app\Notenmanager;;;;;;;;;;1;;;;PC-VN-30
----------------------------------------
# 01.10.2019, 16:17:03
Verbindung zur PostGreSql-Datenbank wurde erfolgreich hergestellt.;;;;CheckPGDB;;comClsDataFile;;NManagerSV;;3;;;;PC-VN-30
----------------------------------------
# 01.10.2019, 16:17:03
------------------------------------------------------------------
LizenzInfo
------------------------------------------------------------------
LizenzStatus    : voll
Lizenzschlüssel : SVL19-XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
Zeugnislizenz   : Wahr
Zeugnislizenznr : XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
------------------------------------------------------------------
DatenbankInfo
------------------------------------------------------------------
Schulart        : 0
Schuljahr       : 2019/2020
------------------------------------------------------------------
Konfiguration
------------------------------------------------------------------
Datum ZZ        : 14.02.2020
Datum JZ        : 24.07.2020
Sport           : Wahr;;;;;;;;;;1;;;;PC-VN-30
----------------------------------------
# 01.10.2019, 16:17:04
Fehler beim Programmstart: Ungültiges Bild. Das Programm wird beendet.;;1810;;Sub Main;;modMain;;NManagerSV;;1;;;;PC-VN-30
----------------------------------------

Vielen Dank für jede Hilfe!

Gruß
Johannes
Zitieren
#2
Hallo Johannes,

schickst du mir bitte einmal die komplette nmsvlog.txt per mail zu?

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#3
Hallo Johannes,

könntest du mir noch die Namen der PCs nennen, an denen es funktioniert und auch, an denen es nicht funktioniert? Ich finde in der Logdatei zuletzt nur vier Rechner, die außer dem Server auf den Notenmanager zugreifen: 05 und 30 bis 32. Die 3 letzten bringen alle die gleichen Fehlermeldungen. Sind das auch die einzigen Rechner, die Probleme machen? Habt ihr noch mehr als diese vier Rechner?

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#4
Hallo Stephan,

der Notenmanager funktioniert auf den Rechnern VN-01, 02, 03, 04, 05. Probleme gibts bei den Geräten mit der Nummer 30, 31, 32, 33. Sobald sich ein Lehrer mit Roaming-Profil zum zweiten Mal an der Domäne anmeldet, wird der Notenmanager nicht mehr gestartet. Beim erstmaligen Bezug des default-Profils ist der Aufruf möglich.
Wenn man den Notenmanager als Administrator aufruft (vergleichbar mit Wolfhards Problem im Thread weiter unten), funktioniert alles.

Viele Grüße
Johannes
Zitieren
#5
Hallo Johannes,

das scheint mir dann aber weniger ein Notenmanager-Problem zu sein als mehr ein Konfigurationsproblem vor Ort. Vielleicht hilft dir folgende Information: Die Logdatei reicht zwar zurück bis zum 19.07.2018, von den Rechnern VN-01 bis VN-04 gibt es aber keinen einzigen Eintrag. Von Rechner VN-05 nur ein paar Zugriffe am 1.10., alle anderen stammern von den Problemrechnern.

Da ich eure Konfiguration vor Ort nicht kenne fallen mir nur die Standardtipps ein: Rechte prüfen, Desktop-Links prüfen (verweisen alle auf das richtige Verzeichnis), sind alle notwendigen Dateien im Programmverzeichnis, ...

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#6
Hallo Stephan,

danke für deine Hilfe. Ich hatte auch schon befürchtet, dass es ein Konfigurations- bzw. Rechteproblem sein könnte.
Sagt dir die Meldung "Fehler beim Programmstart: Ungültiges Bild." irgendetwas?

Viele Grüße
Johannes
Zitieren
#7
Für diese Fehlermeldung gibt es verschiedene Ursachen. Aber alle passen nicht so richtig ins eure Situation (zumindest nicht, wenn die Rechner tatsächlich identische Klone sind).

Eine Ursache könnte eine beschädigte Datei sein. Wenn aber die Rechner geklont sind, sind die lokalen Dlls ja identisch. Den Notenmanager selber startet ihr aber aus dem Netzwerklaufwerk, da haben ja auch alle die gleichen Dateien.

Weitere Möglichkeit: ein Virenscanner funkt dazwischen. Aber auch hier: wenn alle Rechner identisch sind ...

Meine einzige Idee habe ich oben angedeutet: da die Rechner VN-01 bis VN-04 in der Logdatei gar nicht auftauchen heißt das, dass an diesen Rechner der NM noch nie gestartet wurde oder dass diese den Notenmanager aus einem anderen Verzeichnis starten. Denn würden diese Rechner aus dem gleichen Verzeichnis starten, dann würden sie aus der gleichen nmsv.conf lesen und auch die Logdaten in die gleiche Datei wie die anderen Rechner schreiben.

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#8
Ich habe den Notenmanager jeweils über den gleichen Link (Ziel NM Freigabe auf Server) gestartet. Es ist so wie du schreibst: auch bei einem erfolgreichen Start des Notenmanagers wird kein Eintrag in die Log-Datei geschrieben. Den Kaspersky Virenscanner bzw. Firewall habe ich ausgeschaltet, aber das gleiche Fehlerbild bekommen.
Ich denke, dass es - wie du schon erwähnt hast - an den Rechten bei unseren Roaming-Profilen liegt. Wenn ich eine Lösung habe, melde ich mich wieder.
Vielen Dank für deine Unterstützung!
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  NM SV startet auf neuem Client nicht Harald Geiger 3 347 15.07.2019, 13:42
Letzter Beitrag: NM-Himself
  UNC-Pfade und Netzlaufwerke für Client-Installation funktionieren nicht t.mayer 4 1.228 09.10.2018, 22:59
Letzter Beitrag: t.mayer
  Client-Installation (Datenbank) ubv 7 2.878 16.10.2017, 14:45
Letzter Beitrag: NM-Himself
  NM startet nach Update 4.1.54 nicht Koegi 7 3.859 02.07.2014, 09:21
Letzter Beitrag: JSchmitt
  Windows7-Rechner startet NM nicht KuWi 8 5.369 22.01.2013, 18:43
Letzter Beitrag: NM-Himself

Gehe zu:


Deutsche Übersetzung: MyBB.de, Powered by MyBB, © 2002-2019 MyBB Group.