Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bekanntmachungen
Installation auf 2. Terminalserver
#1
Hallo,

wir haben für den Verwaltungsbereich einen neuen 2. Windows Server 2016 TS installiert. Auf diesem TS arbeiten ausschließlich die Lehrer.
Parallel gibt es noch einen alten TS auf dem nur noch die SL arbeitet. Dort ist die NMSV und NMAdmin bereits installiert und eingerichtet.
Wir betreiben den NM mit einer bestehenden Postgresql DB auf einem Fileserver.

Nun möchte ich auf dem neuen TS NMSV und NMAdmin parallel installieren. Ich habe folgendes bereits gemacht:
  • NMadmin installiert.
  • NMSV installiert. (Serverinstallation)
  • psqlodbc_x86 in der aktuellen Version installiert
  • NMPGSetup installiert und die neuen Config. Dateien erstellt (Setup nicht ausgeführt, da die NM DB auf dem Fileserver ja bereits besteht und läuft) die beiden .conf Dateien in das NMSchulversion Verzeichnis kopiert.
Was fehlt noch, mein Wunsch wäre, dass die neue Installation sich einfach mit der bestehenden PostgresDB auf dem Fileserver verknüpft?

Viele Grüße und Vielen Dank!
Zitieren
#2
Hallo,

die conf-Dateien hättest du gar nicht erstellen müssen sondern einfach von der vorhandenen Installation auf die neue kopieren. Ist aber egal, geht auch so. Prinzipiell hast du alles erledigt, was erledigt werden muss. Gegebenenfalls müsstest du auf dem neuen TS noch den Port (vermutlich 5432) in der Firewall öffnen (für ausgehende Anfragen an den PG-Server) und in der pg_hba.conf einen Eintrag für einen neuen IP-Bereich eintragen, wenn der neue TS nicht mehr im IP-Bereich des ersten liegen sollte.

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#3
Danke für die Rückmeldung, leider kommt beim Programmstart immer die Fehlermeldung "Beim Laden der Programmeinstellungen sind Fehler aufgetreten...." und im Anschluss "Der Lizenzschlüssel sei nicht mehr aktuell...".

Auszug aus dem LOG:


# 25.04.2019, 18:38:12
------------------------------------------------------------------
VersionsInfo
------------------------------------------------------------------
DB-Reorgversion :
UpdateNotwendig : Wahr
ReorgNotwendig  : Wahr
Upd.Erfolgreich : nein
ReorgErfolgreich: nein;;;;;;;;;;1;;;;SRVTERM1-V-L
----------------------------------------
# 25.04.2019, 18:38:12
FATAL:  Passwort-Authentifizierung für Benutzer »nmsv0739« fehlgeschlagen
;;370;;OpenConnection;;comClsFunctions;;NManagerSV;;1;;;;SRVTERM1-V-L
----------------------------------------
# 25.04.2019, 18:38:12
Der Vorgang ist für ein geschlossenes Objekt nicht zugelassen.;;110;;Load;;comClsProgState;;NManagerSV;;1;;;;SRVTERM1-V-L
----------------------------------------
# 25.04.2019, 18:38:12
FATAL:  Passwort-Authentifizierung für Benutzer »nmsv0739« fehlgeschlagen
;;370;;OpenConnection;;comClsFunctions;;NManagerSV;;1;;;;SRVTERM1-V-L
----------------------------------------
# 25.04.2019, 18:38:12
Die Verbindung kann nicht verwendet werden, um diesen Vorgang auszuführen.  Sie ist entweder geschlossen oder in diesem Zusammenhang ungültig.;;50;;Class_Initialize;;clsDSLogin;;NManagerSV;;1;;;;SRVTERM1-V-L
----------------------------------------
# 25.04.2019, 18:38:12
Fehler beim Füllen der ComboBox: Typen unverträglich. Das Programm wird fortgesetzt.;;60;;FillBenutzerCombo;;frmLogin;;;;1;;;;SRVTERM1-V-L
----------------------------------------
# 25.04.2019, 18:38:23
FATAL:  Passwort-Authentifizierung für Benutzer »nmsv0739« fehlgeschlagen
;;370;;OpenConnection;;comClsFunctions;;NManagerSV;;1;;;;SRVTERM1-V-L
----------------------------------------
# 25.04.2019, 18:38:23
FATAL:  Passwort-Authentifizierung für Benutzer »nmsv0739« fehlgeschlagen
;;370;;OpenConnection;;comClsFunctions;;NManagerSV;;1;;;;SRVTERM1-V-L
----------------------------------------
# 25.04.2019, 18:38:23
Fehler beim Programmstart: Objekt wurde entladen. Das Programm wird beendet.;;1720;;Sub Main;;modMain;;NManagerSV;;1;;;;SRVTERM1-V-L
----------------------------------------
Zitieren
#4
Dann mach es doch so, wie oben vorgeschlagen: kopier die nmsv.conf und nmadmin.conf vom funktionierenden TS auf den neuen TS. Wenn es dann immer noch nicht geht wird vermutlich eine Firewall dazwischen stehen oder die pg_hba.conf nicht passen. Kannst du mir etwas über die IP-Bereiche des alten und den neuen TS sagen?

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#5
ich habe die beiden .conf Dateien nun auch kopiert und ersetzt. Leider gleiches Bild.

Der alte TS hat 172.17.127.12
der neue TS hat 172.17.127.13

die pg_hba.conf sieht so aus:

# TYPE  DATABASE        USER            ADDRESS    IP-MASK          METHOD
host    all          postgres    172.17.0.0       172.17.127.3       md5
host    mgsd_sabs2   mgsd        172.17.0.0       172.17.127.3       md5
host  mgsd_labs2   mgsd  172.17.0.0       172.17.127.3       md5 
host    bsnm0739     mgsd        172.17.0.0       172.17.127.3       md5
host    bsnm0739     nmmgsd      172.17.0.0       172.17.127.3       md5
host bsnm0739     nmsv0739    172.17.0.0       172.17.127.3       md5
# IPv4 local connections:
host    all             all             172.17.0.0/16            md5
host    all             all             172.17.0.0/16            trust

# IPv6 local connections:
host    all             all             ::1/128                 md5
# Allow replication connections from localhost, by a user with the
# replication privilege.
#host    replication     postgres        127.0.0.1/32            md5
#host    replication     postgres        ::1/128                 md5

Ein FW Problem sollte laut Wartungsfirma der FW ausgeschlossen sein, da sich die Geräte ja im gleichen Netz befinden.
NMAdmin lässt sich mit Benutzer X und unserem Admin PW starten und hat auch die Verbindung zur DB, dort ist alles OK.
Ich habe die Installation Server und Client nochmals probiert. Bisher haben wir nur eine Installation auf dem alten TS laufen, keine weiter auf dem Fileserver.
Zitieren
#6
Hallo,

kleiner Tipp für die zukünftige Kommunikation: je mehr Informationen du schickst in Bezug auf "was geht, was geht nicht", desto schneller kommen wir zum Ziel. großes grinsen  Nach deinem ersten Post war mir noch gar nicht klar, wo das Problem überhaupt liegt, jetzt tasten wir uns langsam ran.

Status quo ist also: NMAdmin und Schulversion funktionieren über den alten TS immer noch, über den neuen TS funktioniert auch NMAdmin, nur die Schulversion kann nicht auf die Datenbank zugreifen.

Wenn dem so ist scheidet die pg_hba und die Firewall natürlich aus, da der Zugriff ja grundsätzlich funktioniert. Wenn du die nmsv.conf vom alten TS kopiert hast und dort die Schulversion funktioniert (bitte noch einmal testen), kann es auch daran nicht liegen. Dann gibt es womöglich Probleme mit dem ODBC-Treiber. Welchen hast du denn heruntergeladen?

Hilfreich wäre vielleicht auch in Blick in die Logdatei von Postgres: im "Data"-Verzeichnis liegt das Verzeichnis "log" darin schön mit Datum und Uhrzeit versehen die einzelnen Logdateien. Versuch noch einmal mit der Schulversion auf dem neuen TS auf die Datenbank zu zugreifen (merk dir die Uhrzeit) und schau anschließend in die neueste Logdatei, ob zu diesem Zeitpunkt etwas vermerkt ist.

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#7
das sagt die pg log Datei, anscheinend ein Problem mit dem PW. Aber bei NMAdmin und der alten Installation auf dem anderen TS geht's ?

2019-04-26 05:30:53 CEST FATAL:  das Datenbanksystem startet
2019-04-26 05:30:53 CEST LOG:  Datenbanksystem wurde am 2019-04-26 05:30:19 CEST heruntergefahren
2019-04-26 05:30:53 CEST LOG:  MultiXact-Member-Wraparound-Schutz ist jetzt aktiviert
2019-04-26 05:30:53 CEST LOG:  Datenbanksystem ist bereit, um Verbindungen anzunehmen
2019-04-26 05:30:53 CEST LOG:  Autovacuum-Launcher startet
2019-04-26 11:50:57 CEST FATAL:  Passwort-Authentifizierung für Benutzer »nmsv0739« fehlgeschlagen
2019-04-26 11:50:57 CEST DETAIL:  Passwort stimmt nicht überein für Benutzer »nmsv0739«.
 Verbindung stimmte mit pg_hba.conf-Zeile 88 überein: »host    all             all             172.17.0.0/16            md5«
2019-04-26 11:51:00 CEST FATAL:  Passwort-Authentifizierung für Benutzer »nmsv0739« fehlgeschlagen
2019-04-26 11:51:00 CEST DETAIL:  Passwort stimmt nicht überein für Benutzer »nmsv0739«.
 Verbindung stimmte mit pg_hba.conf-Zeile 88 überein: »host    all             all             172.17.0.0/16            md5«
2019-04-26 11:51:02 CEST FATAL:  Passwort-Authentifizierung für Benutzer »nmsv0739« fehlgeschlagen
2019-04-26 11:51:02 CEST DETAIL:  Passwort stimmt nicht überein für Benutzer »nmsv0739«.
 Verbindung stimmte mit pg_hba.conf-Zeile 88 überein: »host    all             all             172.17.0.0/16            md5«
2019-04-26 11:51:17 CEST FATAL:  Passwort-Authentifizierung für Benutzer »nmsv0739« fehlgeschlagen
2019-04-26 11:51:17 CEST DETAIL:  Passwort stimmt nicht überein für Benutzer »nmsv0739«.
 Verbindung stimmte mit pg_hba.conf-Zeile 88 überein: »host    all             all             172.17.0.0/16            md5«
Zitieren
#8
Die Schulversion auf dem alten TS funktioniert sicher noch? Dann ist es - wie oben gesagt - vermutlich ein Treiber-Problem.

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#9
ja, die alte Version läuft noch, ich habe extra nochmal getestet.

ich habe alle drei Varianten der Treiber installiert:

[Bild: file.png] psqlodbc_11_00_0000-x64.zip
2018-11-17 13:50:44
3.5 MB
[Bild: file.png] psqlodbc_11_00_0000-x86.zip
2018-11-17 13:50:44
3.0 MB
[Bild: file.png] psqlodbc_11_00_0000.zip
Zitieren
#10
muss ich zufällig irgendwelche .net Framework Komponenten auf dem TS installieren?
Zitieren
#11
Hallo Stephan,

Ich habe nun auch noch die älteren odbc Treiber und der Version 9.3.0300 (laufen auf dem alte Ts)getestet, kein Erfolg. Habe auch nochmal das dB Passwort für nmsv0739 erneuert und beim alten und neuen System die.conf Dateien erneuert. Beim alten System hat das wieder geklappt beim neuen wieder nicht.

Bist du evtl. vor Montag noch telefonisch erreichbar? Der erste Schultag naht, die Kollegen haben bestimmt nach den Ferien einiges zum Eintragen...

Viele Grüße
Zitieren
#12
Hallo Stephan,

Habe heute Fw und Av deaktiviert und Sv und odbc Treiber nochmals neu installiert. Leider immer noch die Fehlermeldungen.
Zusätzlich habe ich das gleiche Installationsvorgehen an einem Win 10 PC im gleichen Netz durchgeführt und die alte nmconf kopiert und eingefügt. Das hat auf Anhieb funktioniert.

Ich verzweifle langsam...

Bist du telefonisch erreichbar?
Zitieren
#13
Hallo,

bzgl. der Treiber musst du erst einmal schauen, welche Version denn überhaupt euer Postgresql-Server hat. Und dann nimmst du einen, der zu dieser Version passt. Sprich: DB-Server mit der Version 9.6 sollte auch mit einem Treiber aus diesem Versionsbereich betrieben werden. Davon abgesehen brauchst du für die Schulversion ausschließlich den 32-bit Treiber, da sie eine 32 bit Anwendung ist. Du solltest vielleicht erstmal alle bisherigen Treiber noch einmal deinstallieren und dann noch einmal den passenden installieren. Haben der alte und der neue TS das gleiche Betriebssystem drauf?

Laut Logdatei scheinen ja die Anfragen beim Postgresql-Server anzukommen, "nur" das Passwort wird nicht akzeptiert. Hast du mal ein simples Passwort ohne Sonderzeichen probiert?

NMAdmin braucht keinen ODBC-Treiber, der bringt seinen eigenen Treiber für das .net-Framework selber mit. Daher kann es aber auch kein Firewall-Problem sein, da sonst NMAdmin ja auch nicht funktionieren würde.

Welche PG-Version läuft denn bei euch auf dem Server?

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#14
Hallo Stephan, der Postgres Server hat Version 9.6, dazu habe ich jetzt auch den Treiber psqlodbc_09_06_0500-x86getestet. Leider Nichts gebracht.

Der alte TS ist ein Windows Server 2012 R2, dort läuft der NM auch noch in der Version 4.6.11
der neue TS ein Windows Server 2016 Standard, dort habe ich die aktuellste Version 4.6.19 installiert.

Das PW habe ich auf 8 Stellen, nur Buchstaben und Zahlen sowie Groß-/Kleinschreibung abgeändert. Kein Erfolg.

Würde es etwas bringen auf dem Fileserver auch noch NMSV zu installieren und dann die Verknüpfung der lokalen Installation auf dem TS dort auszuführen?
Zitieren
#15
Hallo,

unabhängig vom aktuellen Problem: beide TS müssen unbedingt die gleiche NM Version haben, sonst produzierst du Fehler und Inkonsistenzen in der Datenbank. Momentan natürlich noch kein Problem, weil der neue TS noch nicht auf die Datenbank zugreift, aber das solltest du trotzdem schon bald richten.

Von wo du den Notenmanager startest (vom Fileserver oder von der lokalen Festplatte) macht keinen Unterschied, ausgeführt wird das Programm so oder so auf dem lokalen Rechner. Hier kommen höchstens unterschiedliche Regeln von Firewall und Virenscanner zum Einsatz, für den Treiber macht das aber keinen Unterschied.

Hattest du nach der Installation des neuen TS noch Änderungen an der pg_hba.conf vorgenommen? Falls ja, hast du danach den Postgresql-Dienst neu gestartet? Probier mal Folgendes aus: in der pg_hba.conf habt ihr folgende Zeilen

# IPv4 local connections:
host all all 172.17.0.0/16 md5
host all all 172.17.0.0/16 trust

Kommentier mal die erste von den beiden aus, starte auf dem Server, auf dem Postgres installiert ist, den Postgresql-Dienst neu und schau dann, ob du dich anmelden kannst.

Davon abgesehen kannst du mir mal eure ganzen Notenmanager-Konfigurationsdateien an support@notenmanager.net schicken: nmadmin.conf und nmsv.conf jeweils vom alten und vom neuen Server. Nicht, dass da doch irgendwie ein Eintrag nicht stimmt und wir an der völlig falschen Stelle suchen.

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  ThinClient-Installation deinstalliert bei Deinstallation auch Server RichardLeinstein 5 629 11.10.2018, 10:58
Letzter Beitrag: NM-Himself
  UNC-Pfade und Netzlaufwerke für Client-Installation funktionieren nicht t.mayer 4 660 09.10.2018, 22:59
Letzter Beitrag: t.mayer
  Client-Installation (Datenbank) ubv 7 2.363 16.10.2017, 14:45
Letzter Beitrag: NM-Himself
  Installation auf Debian-Server stem 9 3.349 31.08.2017, 08:56
Letzter Beitrag: stem
  NMAdmin-Installation rka 1 1.253 06.02.2017, 15:28
Letzter Beitrag: NM-Himself

Gehe zu:


Deutsche Übersetzung: MyBB.de, Powered by MyBB, © 2002-2019 MyBB Group.