Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bekanntmachungen
Fehlermeldung beim Start - Reorganisation
#1
Seit ein paar Tagen kommt beim Start der NM Schulversion (Access) und Login als Admin die Fehlermeldung, die Datenbank sei nicht auf dem neuesten stand. Ich solle sie sperren und reorganisieren. Das habe ich mehrfach getan, die Meldung kommt aber weiterhin. Ansonsten geht aber alles. Beim Login als Lehrer kommt keine Meldung.

Gruß Johannes
Zitieren
#2
Hallo Johannes,

das Problem tritt meistens dann auf, wenn unterschiedliche Programmversionen auf die Datenbank zugreifen. Das wäre mal der erst Punkt, den ich überprüfen würde.

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#3
Das könnte sein, bei einer Kollegin in der Schulleitung würde nach Neuinstallation die Exe Datei Lokal gestartet. Habe es nun umgestellt. Fehlermeldung bleibt aber beim Start als Admin. Reorganisationen führt noch immer nicht zum Erfolg.
Zitieren
#4
Kannst du mal am Problemrechner den Notenmanager einmal als Benutzer starten, anschließend als Administrator und mir dann die Fehlerlogdatei nmsvlog.txt zumailen (support@notenmanager.net)?

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#5
Hallo Johannes,

auf eurem Server liegt die Programmversion 4.4.27. Bei der Neuinstallation auf dem einen Rechner wurde die Version 4.4.33 installiert und auch gestartet, dabei dann automatisch die Datenbank entsprechend angepasst. Du hast dann die Einstellungen so geändert, dass auch dieser Rechner jetzt wieder vom Server startet.

Aber eben auch die Version 4.4.27, während die Datenbank schon auf 4.4.33 upgegraded wurde. Wenn du die neueste Version auch auf dem Server installierst sollte das Problem erledigt sein.

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#6
Jep, das wars!

Merci
Zitieren
#7
Hallo Stefan,
auch ich habe aktuell das Problem wieder. Was ich nicht verstehe: wir arbeiten seit dem Sommer mit der PostGreSQL Datenbank und starten alle die Anwendung vom Server. Dann dürfte das doch kein Problem mehr machen und das Update auf dem Server reicht aus, dass alle die neue gleiche Version haben. Oder habe ich da einen Denkfehler?
Viele Grüße Heike
Zitieren
#8
Hallo Heike,

im Prinzip ja, in der Praxis gibt es aber immer wieder Wunderlichkeiten.

1. Mit Jet oder Postgres hat das nichts zu tun, das ist alleine eine Frage des Programms.

2. Bist du sicher, dass wirklich von allen Rechnern der Notenmanager auch vom Server gestartet wird? Hat ein Rechner vielleicht eine veraltete lokale Installation? Wenn du selber in die nmsvlog.txt schaust findest du bei jedem Programmstart den Eintrag "Prog-Verzeichnis:". Lass die Datei mal von unten nach oben nach der Zeichenfolge suchen und schau, was da eingetragen ist. Evtl. findest du so den "Bösewicht".

3. Richtig verwunderlich war es vor ein paar Wochen an einer Schule mit dem gleichen Problem. Dort wurden nach einem Update im Abstand von wenigen Minuten aus dem gleichen Verzeichnis auf dem Server ständig unterschiedliche Programmversionen gestartet (immer abwechselnd alt und neu). Erst ein Neustart des Servers hat das Problem gelöst.

Im Zweifelsfall wäre also diese letzte Variante (Server Neustart) vielleicht auch bei euch der Problemlöser.

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Beim NM-Start beginnt auch Office-Nachinstallation Zwi 2 470 09.09.2019, 15:52
Letzter Beitrag: Zwi
  Start, Datenbankdatei SCA 4 2.348 21.09.2017, 07:02
Letzter Beitrag: SCA
  v5 Connector - Fehlermeldung ineedurhelp 6 3.474 27.06.2017, 18:16
Letzter Beitrag: NM-Himself
  Fehlermeldung beim Update auf 4.4.20 andy 2 2.008 18.11.2016, 09:20
Letzter Beitrag: andy
  Teil-Import 2. Halbjahr bricht mit Fehlermeldung ab karin.habel 6 4.682 25.02.2015, 17:15
Letzter Beitrag: karin.habel

Gehe zu:


Deutsche Übersetzung: MyBB.de, Powered by MyBB, © 2002-2020 MyBB Group.