Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bekanntmachungen
Noten in den Vorjahresdaten verschwunden
#1
Hallo Stephan,

zuerst wünsche ich Dir noch einen guten und hoffentlich stressfreien Start ins neue Schuljahr.

Vorneweg, wir haben die PostGres-Variante im Abonnement und ich habe folgendes kleines, aber nicht ganz unbedeutendes Problem.

Ich habe heute das neue Schuljahr über NM-Admin anlegen wollen. Dazu habe ich alle Schritte befolgt, wie eigentlich immer bisher. Die neuen Klassen, Unterrichte und so weiter wurden auch passend angelegt. Dummerweise fehlen, wenn ich auf die Vorjahresdaten umschalte, sämtliche Noten bzw. zugeordneten Unterrichte, so dass zum Beispiel eine Notenübersicht vom letzten Schuljahr nicht erstellt werden kann. Die alten Zeugnisse sind zwar ohne Noten, dafür aber  mit den Bemerkungen noch da, genauso wie - jetzt kommt's - die Noten der eingerichteten Wahlunterrichte.

Das Ganze ist bereits letzte Woche so geschehen, weshalb ich die Datenbank auf den entsprechenden Tag davor zurückgesetzt hatte. Wir hatten noch ein paar Nachschreiber bzw. Nachprüflinge. Die habe ich über das alte Schuljahr noch verwaltet bzw. deren Zeugnisse ausgedruckt und wollte eben heute endlich das neue Jahr einrichten.

Ich bin da etwas ratlos, zumal eine Datenbankprüfung mit allen Häkchen sowohl im Admin-Tool als auch in der SV nichts zu bringen scheint. Ich habe aus lauter Verzweiflung - und weil ich morgen Vormittag die Datenbank ohnehin wieder zurücksetzen werde - auch die DBreparieren.exe starten wollen, allerdings fehlt da der eingetragene Pfad und ich weiß ehrlich gesagt nicht, welchen ich da einsetzen soll.

Kannst Du mir in irgendeiner Form helfen? Langsam zweifel ich nämlich echt an mir selbst... ;-)

Vielen Dank schon einmal.
Liebe Grüße

Benny
Zitieren
#2
Hallo Benny,

dbreparieren ist nur für Jet-Datenbanken, bei Postgres hat das keine Wirkung. Hast du auf das Vorjahr umgeschaltet und dann die Datenbank prüfen lassen? Probier das mal aus.

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#3
Hallo Stephan,

danke für die schnelle Rückmeldung. Das erklärt, warum sich beim Reparieren nichts getan hat... ;-)

Ich habe sowohl im aktuellen als auch im Vorjahr die Datenbank in SV und Admin-Tool prüfen lassen. Die wurde jeweils ohne Fehlermeldung abgeschlossen.

Bei uns in Hof liegt der NM zentral auf dem Server der Stadt. Der zuständige IT-Mitarbeiter hat die Datenbank zurückgesetzt und reorganisiert. Ich werde im Laufe des Tages nochmals einen Import für das neue Schuljahr durchführen und mich dann gegebenenfalls nochmals melden.
Eine Frage hätte ich noch. Mein Plan wäre, dass ich vom aktuellen Stand (altes Schuljahr) eine lokale Sicherung bei mir auf dem Rechner erstelle. Kann ich die dann händisch als Vorjahresdaten importieren, falls das Problem mit den Noten erneut auftreten sollte?

Schöne Grüße
Benny
Zitieren
#4
Hallo Benny,

prinzipiell sollte das funktionieren, aber diese Funktion ist nicht ohne Grund noch als Beta-Version gekennzeichnet. Bevor diesen Schritt in Angriff nimmst gib mir bitte Bescheid.

Wenn du die Sicherung des Vorjahres mit NMAdmin > Beta-Funktionen > Datensicherung erstellst kannst du auf jeden Fall den Import in eine Jet-Datenbank vornehmen und so dann auf die Vorjahresdaten zugreifen.

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#5
Guten Morgen Stephan,
 
seit gestern funktioniert unser Notenmanager weitgehend so, wie er soll.
Ich habe den Import gemacht, allerdings waren die Noten aus dem Vorjahr wieder weg. Danach habe ich in Admin-Tool und SV sowohl im aktuellen als auch im Vorjahr die Datenbankprüfung durchlaufen lassen, worauf die Vorjahresnoten wieder da waren, allerdings verschwanden die Unterrichte, Klassenzuordnungen und so weiter  aus dem aktuellen Schuljahr. Dieses Problem habe ich dann mit einem Neuimport des aktuellen Jahres (ohne Vorjahresdatensicherung) zu beheben versucht, was auch geklappt hat.
So ganz verstehe ich das Problem und auch die Lösung nicht ganz, aber immerhin funktioniert das Ganze jetzt. Seit gestern läuft alles störungsfrei und die Systemsicherung ist auch erfolgreich durchgefüht worden. Also alles gut. ;-)
 
Vielen Dank nochmals für die Unterstützung.

Schöne Grüße
Benny
 
Zitieren
#6
Hallo Benny,

sind Schulversion und NMAdmin bei euch auf dem neuesten Stand? Das "verschwinden" der Noten ist immer nur ein Anzeigeproblem und weißt darauf hin, dass eine Datenbankabfrage nicht zur aktuellen Programmversion passt. Dann muss die Datenbank wieder mit dem entsprechenden Programm geprüft werden.

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#7
Hallo Stephan, 

bei mir tritt das von Benny geschilderte Problem auch auf. Nach dem Umschalten auf die Vorjahresdaten sind im Zeugnisbereich die Bemerkungen und die Wahlfächer vorhanden - die Fachnoten aber alle weg und Unterrichte fehlen in einzelnen Klassen (nach Murphy genau in den Klassen, die ich bräuchte).

Datenprüfung im Vorjahr mit SV und ADMIN brachte keinen Erfolg - Meldung beim Öffnen einer Klasse im Zeugnisbereich lautet "Index außerhalb des gültigen Bereichs.".

Vorhaben wäre das Ausdrucken neuer Zeugnisse nach erfolgreicher Nachprüfung - wie komme ich da ran?

Danke und Gruß
Carsten
Zitieren
#8
Hallo Carsten,

ohne Fehlerlogatei kann ich dazu leider nicht viel sagen. Reproduzier mal den Fehler und schick mir dann die Logdatei zu.

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#9
Hallo Stephan, 

Hab ich schon geschickt wegen der Sache mit den Oberstufenkursen - da müsste der Fehler auch mit drinnen sein.

Jetzt - beim etwa fünften Versuch - bringt er sogar bei der Datenbankprüfung in der Schulversion die Meldung "Es gibt Fehler in der Datenbankstruktur. Bitte kontaktieren Sie den Hersteller." Dafür sind plötzlich aber die Vorjahresnoten da.

Gruß
Carsten
Zitieren
#10
Jepp, habe eben die nmadmin_log.txt bekommen, die Situation klärt sich:

habt ihr in diesem Schuljahr eine andere Verteilung der Notenspalten vorgenommen? Mehr Spalten für mündliche, dafür weniger bei den Stegreifaufgaben (oder umgekehrt)? Dann ist es tatsächlich so, dass immer nur ein Schema (aktuelles Schuljahr oder Vorjahr) funktioniert. Hintergrund: Es werden die Daten für das Vojahr in eigene Tabellen gesichert, die Datenbankabfragen sind aber für beide Schuljahre die Gleichen. Dadurch gibt es beim Schuljahreswechsel jetzt immer Fehler.

Du müsstest also ins Vorjahr umschalten (im schlimmsten Fall SV und NMAdmin), die Datenbank prüfen lassen. Dann sollte der Zugriff auf das Vorjahr funktionieren, auf das aktuelle dann aber nicht. Dann in beiden wieder zurückschalten und wieder Datenbank prüfen.

Ich schau mal, ob sich das besser lösen lässt. Aber im Allgemeinen bleibt ja die Spaltenverteilung über die Jahre gleich.

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#11
Danke für die schnelle Antwort, Stephan - 
ganz ehrlich kann ich das jetzt nicht sagen, ob ich in diesem Jahr eine andere Einstellung genommen habe. Das wird ja beim Einrichten des Schuljahres abgefragt und in diesem Jahr habe ich glaube ich dann 10 / 10 genommen - ob ich da im letzten Jahr was anderes hatte ?! Wahrscheinlich dann; wenn ich jetzt die Problematik kenne, werde ich die Anzahl künftig gleich lassen. 

Man muss aber scheinbar die Datenbank dann mehrmals im Vorjahr prüfen - ich habe bestimmt dreimal in Admin und SV geprüft - irgendwann - als ich den Fehler für das Posting in der log reproduzieren wollte - hat es dann funktioniert. Zuverlässig beim ersten Mal hat das nicht geklappt. 

Gruß
Carsten
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Nacholfristen verschwunden ame 1 184 04.06.2019, 12:03
Letzter Beitrag: NM-Himself
  Wiederherstellung der Vorjahresdaten Billy 13 3.992 09.10.2017, 18:28
Letzter Beitrag: NM-Himself
  rote Bücher verschwunden norbert 1 1.372 15.10.2014, 11:05
Letzter Beitrag: MSchmidl
Sad Unterricht verschwunden norbert 9 5.841 13.07.2009, 17:58
Letzter Beitrag: NM-Himself
  Manuelle Änderung einer Schüleradresse / Button verschwunden Litze 1 979 20.11.2006, 10:26
Letzter Beitrag: NM-Himself

Gehe zu:


Deutsche Übersetzung: MyBB.de, Powered by MyBB, © 2002-2019 MyBB Group.