Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bekanntmachungen
Notenabgleich in Schulversion funktioniert nicht
#1
Hallo!
Es gibt einen entsprechenden Thread schon, allerdings ist der schon etwas älter... daher starte ich das nochmal neu:
Ich habe letzten Donnerstag auf die aktuellen Versionen SV(4.6.41) und Admintool aktualisiert, (Admin-tool heute nochmal aktualisiert). Wir nutzen eine PostGreSQL-Datenbank.
Seit dem Update ist in der Schulversion kein Notenabgleich mehr erfolgreich (mehrere KollegInnen u.a. ich selbst getestet). Die Synchronisation endet mit einer leeren Ergebnisanzeige; Im Hintergrund auf dem Fenster "NMSyncUI" steht "Fehler (Programm wird fortgesetzt)". Schließt man die leere Ergebnisanzeige, so verschwindet das NMSyncUI-Fenster ohne weitere Meldung.
Ich habe dann versucht ein neues Transportmedium zu erstellen. Der entsprechende Ordner war dabei jedes mal leer- keine einzige Datei war enthalten. (Schreibzugriff kann ausgeschlossen werden, da ich die Erstellung auch lokal auf C:\ versucht habe.)

Das System (OS, Virenscanner, Server, ...) wurde seit dem Update des NM nicht verändert.
Ein Prüfen (und Reparieren) der Datenbank (sowohl im NM-SV als auch im Admin-tool) brachte keinen Erfolg. 


Mit der neuesten Heimversion bringt die Synchronisation mit dem USB-Stick keine Fehlermeldung - auch nach einem fehlerhaften Versuch in der Schulversion. In der HV scheint sie zu funktionieren.

PS: die nmsynclog-Meldungen in der SV haben sich seit Donnerstag verändert (falls das weiter hilft):


Code:
[30.01.2020 08:44:58 | v022-2]#Start Sync:08:44:58####ErrorTypeProgrammfehler
[30.01.2020 08:44:58 | v022-2]#System.Security.Cryptography.CryptographicException: Zeichenabstände sind ungültig und können nicht entfernt werden.
   bei System.Security.Cryptography.RijndaelManagedTransform.DecryptData(Byte[] inputBuffer, Int32 inputOffset, Int32 inputCount, Byte[]& outputBuffer, Int32 outputOffset, PaddingMode paddingMode, Boolean fLast)
   bei System.Security.Cryptography.RijndaelManagedTransform.TransformFinalBlock(Byte[] inputBuffer, Int32 inputOffset, Int32 inputCount)
   bei System.Security.Cryptography.CryptoStream.FlushFinalBlock()
   bei nmClasses.clsCrypt.AESDecryptString(String sKey, String sIV, String sTextToDecrypt) in C:\WS_VSOnline\Notenmanager\Main\Notenmanager.net\NMClasses\nmClasses\clsCrypt.vb:Zeile 277.#System.Security.Cryptography.CryptographicException: Zeichenabstände sind ungültig und können nicht entfernt werden.
   bei System.Security.Cryptography.RijndaelManagedTransform.DecryptData(Byte[] inputBuffer, Int32 inputOffset, Int32 inputCount, Byte[]& outputBuffer, Int32 outputOffset, PaddingMode paddingMode, Boolean fLast)
   bei System.Security.Cryptography.RijndaelManagedTransform.TransformFinalBlock(Byte[] inputBuffer, Int32 inputOffset, Int32 inputCount)
   bei System.Security.Cryptography.CryptoStream.FlushFinalBlock()
   bei nmClasses.clsCrypt.AESDecryptString(String sKey, String sIV, String sTextToDecrypt) in C:\WS_VSOnline\Notenmanager\Main\Notenmanager.net\NMClasses\nmClasses\clsCrypt.vb:Zeile 277.#AESDecryptString#clsCrypt#ErrorTypeProgrammfehler
[30.01.2020 08:44:59 | v022-2]#Verbindung zum Server  wurde hergestellt.####ErrorTypeInfo
[30.01.2020 08:44:59 | v022-2]#Systemeinstellungen konnten nicht geladen werden.#Es fehlt ein Argument des ConnectionString!
Parametername: HOST#Load#nmClasses.clsSettings#ErrorTypeProgrammfehler
[30.01.2020 08:44:59 | v022-2]#Lehrerdaten konnten nicht geladen werden#Es fehlt ein Argument des ConnectionString!
Parametername: HOST#InitData#nmclasses.clsTools#ErrorTypeProgrammfehler
[30.01.2020 08:44:59 | v022-2]#Die Fächerliste konnte nicht geladen werden.#Es fehlt ein Argument des ConnectionString!
Parametername: HOST#Load#nmClasses.clsFaecherliste#ErrorTypeProgrammfehler
[30.01.2020 08:44:59 | v022-2]#Fächerdaten konnten nicht geladen werden#Es fehlt ein Argument des ConnectionString!
Parametername: HOST#InitData#nmclasses.clsTools#ErrorTypeProgrammfehler
[30.01.2020 08:44:59 | v022-2]#Die Konfigurationsdaten konnten nicht gelesen werden: Es fehlt ein Argument des ConnectionString!
Parametername: HOST. Es wird versucht, das Programm fortzusetzen.####ErrorTypeWarnung
[30.01.2020 08:44:59 | v022-2]#Systemeinstellungen konnten nicht geladen werden.#Es fehlt ein Argument des ConnectionString!
Parametername: HOST#Load#nmClasses.clsSettings#ErrorTypeProgrammfehler
[30.01.2020 08:44:59 | v022-2]#Lehrerdaten konnten nicht geladen werden#Es fehlt ein Argument des ConnectionString!
Parametername: HOST#InitData#nmclasses.clsTools#ErrorTypeProgrammfehler
[30.01.2020 08:44:59 | v022-2]#Die Fächerliste konnte nicht geladen werden.#Es fehlt ein Argument des ConnectionString!
Parametername: HOST#Load#nmClasses.clsFaecherliste#ErrorTypeProgrammfehler
[30.01.2020 08:44:59 | v022-2]#Fächerdaten konnten nicht geladen werden#Es fehlt ein Argument des ConnectionString!
Parametername: HOST#InitData#nmclasses.clsTools#ErrorTypeProgrammfehler
[30.01.2020 08:45:00 | v022-2]#CurrentSession konnte nicht initialisiert werden: Es fehlt ein Argument des ConnectionString!
Parametername: HOST####ErrorTypeInfo
[30.01.2020 08:45:00 | v022-2]#Die Benutzerdaten von XXX konnten nicht gelesen werden: Es fehlt ein Argument des ConnectionString!
Parametername: HOST####ErrorTypeInfo
[30.01.2020 08:45:00 | v022-2]#System.IndexOutOfRangeException: An der Position 0 befindet sich keine Zeile.
   bei System.Data.RBTree`1.GetNodeByIndex(Int32 userIndex)
   bei System.Data.DataRowCollection.get_Item(Int32 index)
   bei nmClasses.clsSettings.GetStringValue(eSettingsString eData) in C:\WS_VSOnline\Notenmanager\Main\Notenmanager.net\NMClasses\nmClasses\clsSettings.vb:Zeile 600.
   bei NMSyncUI.frmMain.Start() in C:\WS_VSOnline\Notenmanager\Main\Notenmanager.net\nmSyncUI\frmMain.xaml.vb:Zeile 122.#System.IndexOutOfRangeException: An der Position 0 befindet sich keine Zeile.
   bei System.Data.RBTree`1.GetNodeByIndex(Int32 userIndex)
   bei System.Data.DataRowCollection.get_Item(Int32 index)
   bei nmClasses.clsSettings.GetStringValue(eSettingsString eData) in C:\WS_VSOnline\Notenmanager\Main\Notenmanager.net\NMClasses\nmClasses\clsSettings.vb:Zeile 600.
   bei NMSyncUI.frmMain.Start() in C:\WS_VSOnline\Notenmanager\Main\Notenmanager.net\nmSyncUI\frmMain.xaml.vb:Zeile 122.#Main#NMSync.Module1#ErrorTypeProgrammfehler


Obiges ist die Ausgabe bei ein Synchronisationsversuch. Bei der Erstellung eines Transportmediums ist es (soweit ich das beurteilen kann) gleich, außer "start TM" statt "start sync".

Für eine schnelle Hilfe wäre ich dankbar - das Ende des Halbjahres naht...

Vielen Dank!
Florian
Zitieren
#2
Hallo Florian,

bitte beachte, dass je nach Update-Variante NMSync NICHT automatisch aktualisiert wird! Prüf mal die Versionsnummer und hol dir die neueste Version unter https://forum.notenmanager.net/showthread.php?tid=8106

Gruß
Stephan
RSS-Feed mit aktuellen Informationen über Updates, Änderungen in der Programmbedienung und anderen wichtigen Mitteilungen unter http://www.notenmanager.net/feeds/Notenmanager.xml
Zitieren
#3
Hallo Stephan,

vielen Dank! Damit ist das Problem gelöst. Es geht wieder.
Da wäre ich nie drauf gekommen.... hab zwar geschaut ob die Datei vorhanden ist, aber nicht weiter gedacht...

Jedenfalls vielen Dank!
Das Stresslevel ist gerade wieder deutlich gesunken...

Florian
Zitieren


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Notenabgleich dauert sehr lange bofo 1 19 Vor 3 Stunden
Letzter Beitrag: NM-Himself
  Fehler beim Notenabgleich DGoeldner 6 625 28.01.2020, 11:35
Letzter Beitrag: JOs
  Datenaustausch mit Heimversion funktioniert nicht mehr (4.6.40) UliG 6 440 03.12.2019, 10:59
Letzter Beitrag: UliG
  Daten aus dem Notenabgleich werden nicht gespeichert Krellner 1 234 23.10.2019, 17:58
Letzter Beitrag: NM-Himself
  Log bei Notenabgleich in SV? NM_gyp 5 1.354 24.04.2018, 15:32
Letzter Beitrag: NM-Himself

Gehe zu:


Deutsche Übersetzung: MyBB.de, Powered by MyBB, © 2002-2020 MyBB Group.